Lucity Support for ArcGIS 10.5.1

We are pleased to announce that the upcoming Lucity 2017r2 release (Aug 2017) will support Esri® ArcGIS 10.5.1.  Lucity 2017 also supports this latest ArcGIS release.  Earlier versions of Lucity that fall under active maintenance can be upgraded to 10.5.1, but may require some additional steps as outlined in this knowledge base article. Continue reading